Выбор варианта настроек в неуправляемой форме отчета построенного на основе системы компоновки данных (СКД) в пользовательском режиме

Аватар пользователя mykib.org
Файлы для скачивания: 

Варианты настроек отчета указываются на закладке «Настройки»:

Варианты настроек отчета указываются на закладке «Настройки»

Создадим основную форму отчета. В модуле формы вызовем в процедуре «ПриОткрытии» выполним заполнение меню «Варианты отчета»:


Процедура ПриОткрытии()
	
	ЗаполнитьМенюВариантыНастроек();
	
КонецПроцедуры

//Процедура Создает меню "Варианты отчетов" и пункты подменю для выбора вариантов настроек
Процедура ЗаполнитьМенюВариантыНастроек()
	
	//Создание пункта меню
	КнопкиДействияФормы = ЭлементыФормы.ДействияФормы.Кнопки;
	НоваяКнопкаПодменю = КнопкиДействияФормы.Вставить(1,"МенюВариантыОтчетов", ТипКнопкиКоманднойПанели.Подменю, "Варианты отчетов");
	НовоеДействие = Новый Действие("СменитьВариантНастройки");
	
	//Заполнение пункта меню подпунктами
	Сч = 0;
	Для Каждого НастройкаСхемыКомпоновкиДанных Из СхемаКомпоновкиДанных.ВариантыНастроек Цикл
		Сч = Сч + 1;
		НоваяКнопка = КнопкиДействияФормы.МенюВариантыОтчетов.Кнопки.Добавить("ВариантНастройкиОтчета" + Сч, ТипКнопкиКоманднойПанели.Действие, НастройкаСхемыКомпоновкиДанных.Представление, НовоеДействие);
	КонецЦикла;

КонецПроцедуры

Процедура СменитьВариантНастройки(Элемент)
	
	ВыбранныйВариант = СхемаКомпоновкиДанных.ВариантыНастроек.Найти(Элемент.Текст);
	
	Если ВыбранныйВариант > Неопределено Тогда
		
		КомпоновщикНастроек.ЗагрузитьНастройки(ВыбранныйВариант.Настройки);
		
	КонецЕсли;
	
КонецПроцедуры

В результате:

В результате

Ключевые фразы:

Комментарии

Аватар пользователя Алексей

<p>Спасибо! Классный вариант! Очень помог.&nbsp;</p>

Добавить комментарий

CAPTCHA
Этот вопрос для того, чтобы удостовериться действительно ли Вы являетесь человеком и для предотвращения спама.
10 + 0 =
Решите эту простую математическую задачу и введите результат. Например, для 1+3, введите 4.